Home Button  Buy Button 

Topic:   Support Haas

By: BenPosted on: Jan 31 2017 at 07:12:35 PM
Does your RemoDNC support Haas Controls with Serial ports?
Recommended settings?
-Ben

By: GuestPosted on: Feb 3 2017 at 10:52:30 PM
Yes. Works with Haas.

In the haas the settings #11, #12, #13 and 14 are the serial port setup.

9600, 8, N, 1, XModem.

Set the same in RemoDNC.

By: KevinPosted on: Sep 27 2018 at 01:28:52 PM
I've set up my system as above with the exception of my machine's baud rate is 19200. I've set the RemoDNC to 19200 to match. My settings are 19200, 8, N, 1, XModem. On the setup screen, I've got the mode set to Haas and the format to default. I set the Haas to receive and it acknowledges "Waiting. . ." I hit send on RemoDNC and it says "DNC is ready for the XModem file transfer to begin." Then it just sits there with a cancel button as my only option. Any ideas what I'm doing wrong?

By: KevinPosted on: Sep 27 2018 at 02:04:01 PM
It was a cabling issue. But, good to know if it acts like it is connected, but says DNC is ready for the XModem file transfer to begin, check your connections.

By: SupportPosted on: Sep 27 2018 at 02:34:26 PM
Thank you for coming back and telling us about the cable issue.

Yes. it would be good if RemoDNC could detect a faulty cable and display a definitive error message. But unfortunately the xmodem protocol doesn't have any way to signal a faulty cable. All the software can do is assume the CNC operator is taking a break or working somewhere else. The software just faithfully sits and waits listening for the CNC to wake up and start talking.

"I'm concerned that if it said "Waiting to begin, check you cables" then that could make somebody strip out their cables when, in fact, all they need to do was go to the CNC and click the 'receive' button.

Reply - add a comment to this topic.

You may enter letters, numbers and standard punctuation only. HTML and other scripts/tags will be rejected.

Topic:- Support Haas


Enter the numbers.

Your name here is optional