Home Button  Buy Button 

Topic:   085 Error

By: MarkPosted on: May 23 2018 at 12:19:07 PM
I have a Wia VX 400 VMC with a Fanuc 0 Control.
Used to send and receive programs on a laptop with easydnc 4.7.
Laptop died and we downloaded easydnce 4.7 free trial.
Used the same settings as before.and am now able to receive from the cnc.
I cannot send the same program back without getting an instant 085 error.
Have slowed the flow rate as slow as it will go and still get error.

By: GuestPosted on: May 24 2018 at 03:26:18 AM
Unfortunately the 085 is a generic communications error that can have a few different causes.

When all of the communications settings are correct the the 085 is usually caused by a buffer overrun in the CNC and slowing down the baud rate is often the solution for that.

But if communication settings are wrong then any of them can cause 085 error.

How sure are you that the settings are the same as they were on the old computer? Is the new computer the same as the old one or is it a new one. For example did the old one have a proper 9pin com port built into the chassis while the new one is usually USB? What's the difference?

First confirm that you can send from CNC to Computer. Is all the data correct? No point in continuing with the rest of these tests unless cnc-to-computer is faultless.

Next. When you send to the CNC does 'any' data at all go into the CNC before the error occurs? For example does the CNC detect the program number. Usually a fanuc shows the program number as soon as the first line is received even if data error occurs after a few lines.
But if the error occurs as soon as you start sending and the cnc doesn't even see the program number as if it's the very first byte that causes the error then you need to look at the DataBits and Parity setting in EasyDNC.

7Bit/Even Parity. (Most Common)

8bits/None Parity (Occasionally on modern controls)

8bits/Even (NEVER, NEVER EVER 8bits with any parity. 8bits is always NoParity)

7bits/odd parity. (Possible I suppose but never ever seen it before with std ISO)

So, set to 7bits/even parity and try that first.

If cnc gets the program number and a few lines before the alarm occurs then try these things.
Make sure Flow control is enabled. (usually XOnXoff)
Increase the Block Delay in easydnc settings. (bigger number ie not 0 or fast)
In the old computer did you disable Windows FIFO? (windows Control panel>System>Device manager>ComPorts>Advanced) If you disabled FIFO in the old computer then make sure you do it in the new one too. Often makes no difference on some USB adapters on modern computers but disable it anyway if possible.

By: MarkPosted on: May 24 2018 at 09:19:33 AM
Thanks For Your Reply.
The settings for easydnc were documented for the old computer.
Old Computer and New Computer both used USB to 9 Pin Adaptor
Old computer had a Dynex Adaptor but we lost the driver
New computer is using a Belkin Adaptor
I found (in the Belkin USB to 9 pin driver settings) the ability to disable FIFO.
Tried sending program and the program flashed on screen this time before the 085 alarm.
Set easydnc settings to original baud rate and 1ncreased block delay to 200.
It took Longer for the flash of program to appear but still got the alarm.
We are getting closer; but not there yet.

By: GuestPosted on: May 24 2018 at 12:24:45 PM
What baud rate do you have?

By: MarkPosted on: May 25 2018 at 08:17:37 AM

By: GuestPosted on: May 25 2018 at 12:45:05 PM
4800 shouldn't be too fast for a fanuc. But to reduce the chance of an overflow can you try baud rate 1200. Obviously change the baud rate in the cnc as well as in easydnc.
You didn't say what the other settings were. Databits, parity etc. Flow control?

Reply - add a comment to this topic.

You may enter letters, numbers and standard punctuation only. HTML and other scripts/tags will be rejected.

Topic:- 085 Error

Enter the numbers.

Your name here is optional