Home Button  Buy Button 

Topic:   Trouble with Bridgeport DX32

By: GuestPosted on: Nov 17 2016 at 02:35:45 PM
The files seem to transfer but it doesn't seem to want to end transmission. The DX32 just waits and waits, and I have to manually cancel out the transmission at the mill. I assume I don't have everything setup properly. Any thoughts?

By: SupportPosted on: Nov 17 2016 at 09:43:37 PM
The CNC is waiting for the End of File marker.

Go into the DNC setup and you'll see the big 'Advanced Options' button. Click that and select the 'EOT' option for the 'Ascii End Code'.

Did that help?

By: GuestPosted on: Nov 18 2016 at 01:13:17 PM
So all the DX32 is looking for is an "EOT" at the last line of my G-Code?

Is that something I could just add to my file if I wanted to? Or will that not work the same?

By: GuestPosted on: Nov 18 2016 at 06:48:47 PM
EOT is not a character on your keyboard so you can't key it in. The option in the DNC software just appends that character at the end of the file when sending to the CNC.

But if you really want to key EOT into a program manually then using something like Windows NotePad, you can press/ hold down the Alt key and enter 004 on the numerical keypad and then release the alt key. That inserts the EOT character at the cursor.

Another way. If you receive data "from" the cnc and can see a strange symbol at the end of the file then that is the EOT. You could copy and paste that symbol to the bottom of any other file that you want to send to the CNC. That ought to do it as well.

All of the above might work but surely it's just easier to let the dnc software do it automatically via that Ascii EndCode option in the dnc setup.

Reply - add a comment to this topic.

You may enter letters, numbers and standard punctuation only. HTML and other scripts/tags will be rejected.

Topic:- Trouble with Bridgeport DX32

Enter the numbers.

Your name here is optional