Home Button  Buy Button 

Topic:   Fanuc 10M - Buffer Overflow 2

By: Daniel Pereira - PortugalPosted on: Oct 15 2012 at 04:03:21 PM
Hello,

I'm trying to work in dnc mode with a Fanuc 10M but i'm having an error when I'm sending the program to the machine after about 2min. I'm unexperied!

I can send and receive programs or parameters. The machine parameters are: baund rate 9600; even; 1 stop bit;

I've searched in the web and they told the soluction is stting the block delay to: 300 ms

My problem is that I can't change this set to 300 ms in the easyDNC 4.7a. The option is from 10 to 200ms and "Fast".

Someone can help me?

By: Guest Posted on: Oct 15 2012 at 08:16:40 PM
Dont use block delay Fast. That is the same as setting block delay zero. You should use a big number not a small one. Bigger block delay makes comms run slower giving the CNC time to clear its buffers.

But 300ms block delay would be very slow. What happens if you set 200?

If you need a block delay as high as 300 then you'd probably be better going down to a lower baud rate and then use a smaller block delay.

But first thing to do is disable Windows FIFO.

Control panel > system> hardware > device manager. Select the com port and go to advanced. You'll see sliders that you should slide all the way to the left and then uncheck the box to disable FIFO.

Next thing is the baud rate. Start quite slow at 2400 That may starve the machine even with block delay at zero/fast. Increase the baud rate to 4800 and see how that goes. Basically you want to run with the baud rate as low as possible but not so low that it causes the CNC to starve, jerk and stutter through lack of data.




By: Thrun Manufacturing IncPosted on: Jan 23 2013 at 09:00:10 PM
The FIFO has to change. That is for sure. I have 4 machines that run on the Fanuc control and I was having the same damn problem. The program would drip feed for a few passes then the Overflow alarm would kick in.

We had to make some changes to the settings in the EASYDNC software settings. They were as follows: Mode-Standard, Com-Which ever one you have selected, Data rate-1200, FlowControl-Xon/Xoff, Data Bits-7, Stop Bits-1, Parity-Even, Block End-CRLF, Block Delay-10 and check Force CR/LF.

The key one was the block delay. I have a couple fanuc 11M machines and the block delay is set to 5, but the fanuc 10M requires a block delay of 10. I hope this helps.

By: GuestPosted on: Nov 16 2014 at 09:12:46 AM
what is the system error (E ) ? replace master pcb Rom ، pcb or Nc software Rom


IN fanuc 10

By: GuestPosted on: Nov 16 2014 at 09:02:59 PM
Sorry. Never heard of that one before. It's nothing to do with DNC tho
Sounds like an error in one of the system ROM chips. I'd say you need to be calling in your local Fanuc rep.

By: HadiPosted on: Aug 7 2015 at 06:00:51 PM
I have the same problem with fanuc 10M by cimco edit v6.
baud rate = 4800
parity = even
data bits = 7
syop bits = 2
what should i do !!
please help me.
Thanks

By: GuestPosted on: Aug 7 2015 at 07:15:14 PM
Hadi.
Try downloading and installing RemoDNC. Then look at the answers above.

By: WINTECPosted on: Jun 21 2016 at 07:29:30 AM
how to copy a program in fanuc 10m machine?

By: GuestPosted on: Jun 22 2016 at 08:04:48 PM
Note about the FIFO change. Be sure to restart your computer. I spent a hole day trying to get my 10M controller to drip feed. After restarting my computer drip feed worked perfectly.

Reply - add a comment to this topic.

You may enter letters, numbers and standard punctuation only. HTML and other scripts/tags will be rejected.

Topic:- Fanuc 10M - Buffer Overflow 2


Enter the numbers.

Your name here is optional